Posted on March 19, 2008 at 9:52 pm

suPHP you!

An interesting default change, coupled with a goof on our part caused suPHP to stop working on one of our customer’s servers.  They removed the hardcoded handler – x-httpd-php, in favor of a suPHP_AddHandler directive.  Compound failure on our part though, we removed the suphp.conf file.  So if you’re upgrading from Debian 3.X to 4.0 or older suPHP to newer suPHP, check to make sure you’re putting in that suPHP_AddHandler!  Debian will do it for you, as long as you Do The Right Thing(tm) and override rather than ovewrite the mods-available/suphp.conf file.

 

Tags:, ,